package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)\d{1,2}\-\d{1,2}\-\d{2,4}`)
var str = `1-1-18
01-01-2018
1-01-2018
01-1-2018
01-01-18
01-1-18
1-01-18
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}