import Foundation
let pattern = #"""
(\s+by\s+)(?<alias>[a-zA-Z-]{3,22})
"""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
--> Triage: (nothing) -> Approved
===== Edited by dhaffner on 06/18/2015 10:42AM =====
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}