package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\s+by\s+)(?<alias>[a-zA-Z-]{3,22})
`)
var str = ` --> Triage: (nothing) -> Approved
===== Edited by dhaffner on 06/18/2015 10:42AM =====`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}