#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\s+by\s+)(?<alias>[a-zA-Z-]{3,22})" & @CRLF & _
""
Local $sString = " --> Triage: (nothing) -> Approved" & @CRLF & _
"===== Edited by dhaffner on 06/18/2015 10:42AM ====="
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")