use strict;
my $str = ' --> Triage: (nothing) -> Approved
===== Edited by dhaffner on 06/18/2015 10:42AM =====';
my $regex = qr/(\s+by\s+)(?<alias>[a-zA-Z-]{3,22})
/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}