using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\s+by\s+)(?<alias>[a-zA-Z-]{3,22})
";
string input = @" --> Triage: (nothing) -> Approved
===== Edited by dhaffner on 06/18/2015 10:42AM =====";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}