$re = '/(\s+by\s+)(?<alias>[a-zA-Z-]{3,22})
/';
$str = ' --> Triage: (nothing) -> Approved
===== Edited by dhaffner on 06/18/2015 10:42AM =====';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);