const regex = /(\s+by\s+)(?<alias>[a-zA-Z-]{3,22})
/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\s+by\\s+)(?<alias>[a-zA-Z-]{3,22})
', '')
const str = ` --> Triage: (nothing) -> Approved
===== Edited by dhaffner on 06/18/2015 10:42AM =====`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}