import Foundation
let pattern = #"^\d\-\d$|^[a-zA-Z]\-[a-zA-Z]$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
2-3
2-6
a-e
f-y
^-j
A-Z
A-E
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"£"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)