# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\d\-\d$|^[a-zA-Z]\-[a-zA-Z]$/£/mg;t' <<< "2-3
2-6
a-e
f-y
^-j
A-Z
A-E"