import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d\\-\\d$|^[a-zA-Z]\\-[a-zA-Z]$";
final String string = "2-3\n"
+ "2-6\n"
+ "a-e\n"
+ "f-y\n"
+ "^-j\n"
+ "A-Z\n"
+ "A-E";
final String subst = "£";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}