using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d\-\d$|^[a-zA-Z]\-[a-zA-Z]$";
string substitution = @"£";
string input = @"2-3
2-6
a-e
f-y
^-j
A-Z
A-E";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}