$re = '/^\d\-\d$|^[a-zA-Z]\-[a-zA-Z]$/m';
$str = '2-3
2-6
a-e
f-y
^-j
A-Z
A-E';
$subst = "£";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;