use strict;
my $str = '2-3
2-6
a-e
f-y
^-j
A-Z
A-E';
my $regex = qr/^\d\-\d$|^[a-zA-Z]\-[a-zA-Z]$/mp;
my $subst = '£';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";