const regex = /^\d\-\d$|^[a-zA-Z]\-[a-zA-Z]$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d\\-\\d$|^[a-zA-Z]\\-[a-zA-Z]$', 'mg')
const str = `2-3
2-6
a-e
f-y
^-j
A-Z
A-E`;
const subst = `£`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);