import Foundation
let pattern = #"^[0-9]{30}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
ddsfsf2f55fs2fs12f55sf5
221156551516514654303155155465
fsfsfsfsfsfsffsfsdwerwrerwerwr
rwrwrwrwrwrwerwFSFSFSFSFDsfsfsf
123255465476134646346846564963
565464ff56546464646461316fsdfs
5555
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)