import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[0-9]{30}$";
final String string = "ddsfsf2f55fs2fs12f55sf5\n"
+ "221156551516514654303155155465\n"
+ "fsfsfsfsfsfsffsfsdwerwrerwerwr\n"
+ "rwrwrwrwrwrwerwFSFSFSFSFDsfsfsf\n"
+ "123255465476134646346846564963\n"
+ "565464ff56546464646461316fsdfs\n"
+ "5555";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}