package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[0-9]{30}$`)
var str = `ddsfsf2f55fs2fs12f55sf5
221156551516514654303155155465
fsfsfsfsfsfsffsfsdwerwrerwerwr
rwrwrwrwrwrwerwFSFSFSFSFDsfsfsf
123255465476134646346846564963
565464ff56546464646461316fsdfs
5555`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}