$re = '/^[0-9]{30}$/m';
$str = 'ddsfsf2f55fs2fs12f55sf5
221156551516514654303155155465
fsfsfsfsfsfsffsfsdwerwrerwerwr
rwrwrwrwrwrwerwFSFSFSFSFDsfsfsf
123255465476134646346846564963
565464ff56546464646461316fsdfs
5555';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);