# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[0-9]{30}$"
test_str = ("ddsfsf2f55fs2fs12f55sf5\n"
"221156551516514654303155155465\n"
"fsfsfsfsfsfsffsfsdwerwrerwerwr\n"
"rwrwrwrwrwrwerwFSFSFSFSFDsfsfsf\n"
"123255465476134646346846564963\n"
"565464ff56546464646461316fsdfs\n"
"5555")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.