use strict;
my $str = 'ddsfsf2f55fs2fs12f55sf5
221156551516514654303155155465
fsfsfsfsfsfsffsfsdwerwrerwerwr
rwrwrwrwrwrwerwFSFSFSFSFDsfsfsf
123255465476134646346846564963
565464ff56546464646461316fsdfs
5555';
my $regex = qr/^[0-9]{30}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}