// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[0-9]{30}$").unwrap();
let string = "ddsfsf2f55fs2fs12f55sf5
221156551516514654303155155465
fsfsfsfsfsfsffsfsdwerwrerwerwr
rwrwrwrwrwrwerwFSFSFSFSFDsfsfsf
123255465476134646346846564963
565464ff56546464646461316fsdfs
5555";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}