use strict;
my $str = 'NCIS.Los.Angeles.s12e13.(2021) 720p.HEVC.x265-MeGusta[eztv.re]';
my $regex = qr/\).*$/mp;
my $subst = ')';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";