const regex = /\).*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\).*$', 'gm')
const str = `NCIS.Los.Angeles.s12e13.(2021) 720p.HEVC.x265-MeGusta[eztv.re]`;
const subst = `)`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);