import Foundation
let pattern = #"SELECT\s(.+)\sFROM\s(((?!\sWHERE).)+)(\sWHERE\s(.+))?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"SELECT 1 FROM table_name AS b WHERE id=3"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"FROM $2 WHERE $5 GET $1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)