# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/SELECT\s(.+)\sFROM\s(((?!\sWHERE).)+)(\sWHERE\s(.+))?/FROM $2 WHERE $5 GET $1/g;t' <<< "SELECT 1 FROM table_name AS b WHERE id=3"