re = /SELECT\s(.+)\sFROM\s(((?!\sWHERE).)+)(\sWHERE\s(.+))?/
str = 'SELECT 1 FROM table_name AS b WHERE id=3'
subst = 'FROM $2 WHERE $5 GET $1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result