import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "SELECT\\s(.+)\\sFROM\\s(((?!\\sWHERE).)+)(\\sWHERE\\s(.+))?";
final String string = "SELECT 1 FROM table_name AS b WHERE id=3";
final String subst = "FROM $2 WHERE $5 GET $1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}