using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"SELECT\s(.+)\sFROM\s(((?!\sWHERE).)+)(\sWHERE\s(.+))?";
string substitution = @"FROM $2 WHERE $5 GET $1";
string input = @"SELECT 1 FROM table_name AS b WHERE id=3";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}