use strict;
my $str = 'SELECT 1 FROM table_name AS b WHERE id=3';
my $regex = qr/SELECT\s(.+)\sFROM\s(((?!\sWHERE).)+)(\sWHERE\s(.+))?/p;
my $subst = 'FROM $2 WHERE $5 GET $1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";