const regex = /SELECT\s(.+)\sFROM\s(((?!\sWHERE).)+)(\sWHERE\s(.+))?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('SELECT\\s(.+)\\sFROM\\s(((?!\\sWHERE).)+)(\\sWHERE\\s(.+))?', 'g')
const str = `SELECT 1 FROM table_name AS b WHERE id=3`;
const subst = `FROM $2 WHERE $5 GET $1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);