import Foundation
let pattern = #"(assertTrue)(.+?)( ==)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
$this->assertTrue($post->item_id == $actionItem->id);
$this->assertTrue($post->action == 'edited');
$this->assertTrue($post->type == 'Action Item');
$this->assertTrue($post->title == $actionItem->title);
Designed for use in PHPstorm. REGEX in First "Replace" string, and the following in the second:
AssertEquals$2,
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)