package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(assertTrue)(.+?)( ==)`)
var str = ` $this->assertTrue($post->item_id == $actionItem->id);
$this->assertTrue($post->action == 'edited');
$this->assertTrue($post->type == 'Action Item');
$this->assertTrue($post->title == $actionItem->title);
Designed for use in PHPstorm. REGEX in First "Replace" string, and the following in the second:
AssertEquals$2,`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}