const regex = /(assertTrue)(.+?)( ==)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(assertTrue)(.+?)( ==)', 'g')
const str = ` \$this->assertTrue(\$post->item_id == \$actionItem->id);
\$this->assertTrue(\$post->action == 'edited');
\$this->assertTrue(\$post->type == 'Action Item');
\$this->assertTrue(\$post->title == \$actionItem->title);
Designed for use in PHPstorm. REGEX in First "Replace" string, and the following in the second:
AssertEquals\$2,`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}