#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(assertTrue)(.+?)( ==)"
Local $sString = " $this->assertTrue($post->item_id == $actionItem->id);" & @CRLF & _
" $this->assertTrue($post->action == 'edited');" & @CRLF & _
" $this->assertTrue($post->type == 'Action Item');" & @CRLF & _
" $this->assertTrue($post->title == $actionItem->title);" & @CRLF & _
"" & @CRLF & _
"Designed for use in PHPstorm. REGEX in First "Replace" string, and the following in the second:" & @CRLF & _
"AssertEquals$2,"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")