$re = '/(assertTrue)(.+?)( ==)/';
$str = ' $this->assertTrue($post->item_id == $actionItem->id);
$this->assertTrue($post->action == \'edited\');
$this->assertTrue($post->type == \'Action Item\');
$this->assertTrue($post->title == $actionItem->title);
Designed for use in PHPstorm. REGEX in First "Replace" string, and the following in the second:
AssertEquals$2,';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);