use strict;
my $str = ' $this->assertTrue($post->item_id == $actionItem->id);
$this->assertTrue($post->action == \'edited\');
$this->assertTrue($post->type == \'Action Item\');
$this->assertTrue($post->title == $actionItem->title);
Designed for use in PHPstorm. REGEX in First "Replace" string, and the following in the second:
AssertEquals$2,';
my $regex = qr/(assertTrue)(.+?)( ==)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}