// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(assertTrue)(.+?)( ==)").unwrap();
let string = " $this->assertTrue($post->item_id == $actionItem->id);
$this->assertTrue($post->action == 'edited');
$this->assertTrue($post->type == 'Action Item');
$this->assertTrue($post->title == $actionItem->title);
Designed for use in PHPstorm. REGEX in First \"Replace\" string, and the following in the second:
AssertEquals$2,";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}