import Foundation
let pattern = #"{(?:[A-Za-z_][A-Za-z_0-9]*|[+\-*/%<=>&|()0-9. ])*}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
// \%def{ Value3 , name.len + (i * Person.age) + ( }
// %if{ (name.len == 20) && (value == 20) }
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"hello"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)