use strict;
my $str = '// \\%def{ Value3 , name.len + (i * Person.age) + ( }
// %if{ (name.len == 20) && (value == 20) }';
my $regex = qr/{(?:[A-Za-z_][A-Za-z_0-9]*|[+\-*/%<=>&|()0-9. ])*}/p;
my $subst = 'hello';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";