using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{(?:[A-Za-z_][A-Za-z_0-9]*|[+\-*/%<=>&|()0-9. ])*}";
string substitution = @"hello";
string input = @"// \%def{ Value3 , name.len + (i * Person.age) + ( }
// %if{ (name.len == 20) && (value == 20) }";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}