// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"{(?:[A-Za-z_][A-Za-z_0-9]*|[+\-*/%<=>&|()0-9. ])*}").unwrap();
let string = "// \\%def{ Value3 , name.len + (i * Person.age) + ( }
// %if{ (name.len == 20) && (value == 20) }";
let substitution = "hello";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}