re = /{(?:[A-Za-z_][A-Za-z_0-9]*|[+\-*\/%<=>&|()0-9. ])*}/
str = '// \\%def{ Value3 , name.len + (i * Person.age) + ( }
// %if{ (name.len == 20) && (value == 20) }'
subst = 'hello'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result