const regex = new RegExp('{(?:[A-Za-z_][A-Za-z_0-9]*|[+\\-*/%<=>&|()0-9. ])*}', 'g')
const str = `// \\%def{ Value3 , name.len + (i * Person.age) + ( }
// %if{ (name.len == 20) && (value == 20) }`;
const subst = `hello`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);