import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{(?:[A-Za-z_][A-Za-z_0-9]*|[+\\-*/%<=>&|()0-9. ])*\\}";
final String string = "// \\%def{ Value3 , name.len + (i * Person.age) + ( }\n"
+ "// %if{ (name.len == 20) && (value == 20) }";
final String subst = "hello";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}