// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)'(\\x[0-9a-fA-F]{2}|\\u[0-9a-fA-F]{4})*'").unwrap();
let string = "'\\x0F'
'\\u0fff'
'23'
'teset'
'wer.fee'
'\\x0FF'
'\\u0fff\\x'
'\\u0fff\\'\\'
'\\u0fff\"'
'\\u0fff\\b'
'\\u0fff\\f'
'\\u0fff\\n'
'\\u0fff\\r'
'\\u0fff\\t'
'\\u0fff\\v'
'\\u0fff\\n'
'\\u0fff\\\\'
'\\u0fff\\r'
'\\u0fff\\\\u2028'
'\\u0fff\\\\u2029'";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}