using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"'(\\x[0-9a-fA-F]{2}|\\u[0-9a-fA-F]{4})*'";
string input = @"'\x0F'
'\u0fff'
'23'
'teset'
'wer.fee'
'\x0FF'
'\u0fff\x'
'\u0fff\'\'
'\u0fff""'
'\u0fff\b'
'\u0fff\f'
'\u0fff\n'
'\u0fff\r'
'\u0fff\t'
'\u0fff\v'
'\u0fff\n'
'\u0fff\\'
'\u0fff\r'
'\u0fff\\u2028'
'\u0fff\\u2029'";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}