const regex = /'(\\x[0-9a-fA-F]{2}|\\u[0-9a-fA-F]{4})*'/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\'(\\\\x[0-9a-fA-F]{2}|\\\\u[0-9a-fA-F]{4})*\'', 'gm')
const str = `'\\x0F'
'\\u0fff'
'23'
'teset'
'wer.fee'
'\\x0FF'
'\\u0fff\\x'
'\\u0fff\\'\\'
'\\u0fff"'
'\\u0fff\\b'
'\\u0fff\\f'
'\\u0fff\\n'
'\\u0fff\\r'
'\\u0fff\\t'
'\\u0fff\\v'
'\\u0fff\\n'
'\\u0fff\\\\'
'\\u0fff\\r'
'\\u0fff\\\\u2028'
'\\u0fff\\\\u2029'`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}