package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)'(\\x[0-9a-fA-F]{2}|\\u[0-9a-fA-F]{4})*'`)
var str = `'\x0F'
'\u0fff'
'23'
'teset'
'wer.fee'
'\x0FF'
'\u0fff\x'
'\u0fff\'\'
'\u0fff"'
'\u0fff\b'
'\u0fff\f'
'\u0fff\n'
'\u0fff\r'
'\u0fff\t'
'\u0fff\v'
'\u0fff\n'
'\u0fff\\'
'\u0fff\r'
'\u0fff\\u2028'
'\u0fff\\u2029'`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}