re = /'(\\x[0-9a-fA-F]{2}|\\u[0-9a-fA-F]{4})*'/m
str = '\'\\x0F\'
\'\\u0fff\'
\'23\'
\'teset\'
\'wer.fee\'
\'\\x0FF\'
\'\\u0fff\\x\'
\'\\u0fff\\\'\\\'
\'\\u0fff"\'
\'\\u0fff\\b\'
\'\\u0fff\\f\'
\'\\u0fff\\n\'
\'\\u0fff\\r\'
\'\\u0fff\\t\'
\'\\u0fff\\v\'
\'\\u0fff\\n\'
\'\\u0fff\\\\\'
\'\\u0fff\\r\'
\'\\u0fff\\\\u2028\'
\'\\u0fff\\\\u2029\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end